RP 3.9 Bugs and Feedback

 
  David Peters Dr Beeching

Location: "With Hey Boy".
While not having seen an outage page for a while, the site is certainly a lot faster now!

Sponsored advertisement

  JoppaJunction Chief Train Controller

Location: Banned
While not having seen an outage page for a while, the site is certainly a lot faster now!
David Peters

Seems to be a lot better.
  freightgate Minister for Railways

Location: Albury, New South Wales
The outage page appeared again earlier this morning.
  railblogger Chief Commissioner

Location: At the back of the train, quitely doing exactly what you'd expect.
Noticed the post reputation idea has been implemented. I think that it would improve the usability of the site if the related buttons were positioned alongside the 'Reply via PM', 'Herring' and report post buttons. I don't believe they are going to be noticed where they are.
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Noticed the post reputation idea has been implemented. I think that it would improve the usability of the site if the related buttons were positioned alongside the 'Reply via PM', 'Herring' and report post buttons. I don't believe they are going to be noticed where they are.
railblogger
Not enough space Smile It's an idea I already tried and dismissed.
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
In addition, a quick Help article has been created. Yes, it's a bit thin at the moment, but as I get more time I'll flesh it out a bit more. I also plan on improving the look and feel of it a bit more Smile
  railblogger Chief Commissioner

Location: At the back of the train, quitely doing exactly what you'd expect.
Not enough space Smile It's an idea I already tried and dismissed.
michaelgreenhill
Even with just the icons?
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Even with just the icons?
railblogger
With just icons, yes, but icons aren't the only elements in that row Smile
  ARodH Chief Train Controller

Location: East Oakleigh, Vic
Has issues with the menu bar permanently overlaying the upper forum tree links (Home> Forums>....) in iOS Safari, and in the process of submitting a post the embedded links to photobucket images get corrupted resulting in an blank image trying to be rendered and a unrequested URL link been brought up before?
  JoppaJunction Chief Train Controller

Location: Banned
Running the new experimental menu bar. displayed a loco correction which when i clicked on the link produced a broken page with just the banner.

https://www.railpage.com.au/locos/corrections
  s3_gunzel Not a gunzel developer

Location: Western Sydney, AU
Running the new experimental menu bar. displayed a loco correction which when i clicked on the link produced a broken page with just the banner.

https://www.railpage.com.au/locos/corrections
BenGibbons
It's a non-access issue Smile
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Has issues with the menu bar permanently overlaying the upper forum tree links (Home> Forums>....) in iOS Safari,
ARodH

Can you supply a screenshot please?

and in the process of submitting a post the embedded links to photobucket images get corrupted resulting in an blank image trying to be rendered and a unrequested URL link
ARodH
Can you provide a sample post and Photobucket image for testing?

Cheers
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Running the new experimental menu bar. displayed a loco correction which when i clicked on the link produced a broken page with just the banner.

https://www.railpage.com.au/locos/corrections
BenGibbons
Ta, has been brought up before. My focus will return to the new notification flyout soon Smile
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
The bug with the downloads module not sending files to the browser should now be fixed.
  railblogger Chief Commissioner

Location: At the back of the train, quitely doing exactly what you'd expect.
The bug with the downloads module not sending files to the browser should now be fixed.
michaelgreenhill
Can confirm that. Just successfully downloaded the MSTS Comengs.
  X'Trapolis-904M Deputy Commissioner

Location: Melbourne
And when i upload a wav file it does not upload tried this with a interview
  ARodH Chief Train Controller

Location: East Oakleigh, Vic
Can you supply a screenshot please?

Can you provide a sample post and Photobucket image for testing?

Cheers
michaelgreenhill


That image is on photobucket, and the issue wasn't present. It might be a timing thing with taking a long typing out a post and including an embedded image breaking something.
  JimYarin Chief Commissioner

Location: Adelaide, South Australia
Letting you know the front page of RP is broken when it comes to the sponsored advertising.  The ads are not displaying correctly.

I also wanted to say how impressed I am with the new site works and the recent changes and bug fixes.  I also note the download section appears to be working for downloads.
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Letting you know the front page of RP is broken when it comes to the sponsored advertising.  The ads are not displaying correctly.

I also wanted to say how impressed I am with the new site works and the recent changes and bug fixes.  I also note the download section appears to be working for downloads.
JimYarin
Yes, it seems that a recent change to how we deliver JavaScript files to improve page painting times has broken Google AdSense. Sigh.
  JimYarin Chief Commissioner

Location: Adelaide, South Australia
Yes, it seems that a recent change to how we deliver JavaScript files to improve page painting times has broken Google AdSense. Sigh.
michaelgreenhill

OK. Just wanted to provide the feedback.  The site is looking absolutely magic.

Were my eyes seeing things? Jobs ads?
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
OK. Just wanted to provide the feedback.  The site is looking absolutely magic.

Were my eyes seeing things? Jobs ads?
JimYarin
The Jobs module was launched at the start of this year.
  JimYarin Chief Commissioner

Location: Adelaide, South Australia
Flatmate is trying to register on RP as we are TS2015'ing.

Getting the following message when trying to register via Google.

Standard Gmail account running Windows 7. Using IE. We will try with google chrome.

We get to the part where we are asked for the Username we wish to use.


Whoops! exception 'Exception' with message 'Can't find user - no email address provided' in /srv/Railpage.com.au/www/public_html/vendor/Railpage/railpagecore/lib/Users/Base.php:175 Stack trace: #0 /srv/Railpage.com.au/www/public_html/modules/Registration/inc.register.oauth.complete.php(24): RailpageUsersBase->getUserFromEmail(NULL, NULL) #1 /srv/Railpage.com.au/www/public_html/modules/Registration/index.php(29): require_once('/srv/Railpage.c...') #2 /srv/Railpage.com.au/www/public_html/modules.php(97): require_once('/srv/Railpage.c...') #3 {main}
Whoops! User must have an email address
  BigBoy2015 Station Master

We are now both on here.  We were able to create the account using chrome.  Could be an IE issue.
  freightgate Minister for Railways

Location: Albury, New South Wales
Have there been any changes to the mobile UI in the last update.

The forum posts are not rendering correctly on an IOS device.
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Have there been any changes to the mobile UI in the last update.

The forum posts are not rendering correctly on an IOS device.
freightgate
Screenshots, please.

Sponsored advertisement

Display from:   

Quick Reply

We've disabled Quick Reply for this thread as it was last updated more than six months ago.