RP 3.10 Bugs and Feedback

 
  Transtopic Chief Commissioner

Location: Sydney
I'm not sure if this is the correct place for this query, but can anyone explain how you respond to multiple quotes in a single reply?
Quote the first post - and then you have to type the quote tags for the other quotes. It's a bit cumbersome.



So the basis is quote={username} and /quote in the square brackets.
s3_gunzel
Thanks for that.

Sponsored advertisement

  WimbledonW Chief Train Controller

Location: Sydney
There appear to be flaws in the PREVIEW function.


See https://www.railpage.com.au/f-p2231415.htm#2231415
  WimbledonW Chief Train Controller

Location: Sydney
This may not be a bug, but web thread titles cannot contain a hyphen "-".

See https://www.railpage.com.au/f-t11401728.htm

WW
  WimbledonW Chief Train Controller

Location: Sydney
A new post can contain a "Space-separated list of tags to apply to this post."

What are these tags for, and can they be searched for?

This is not necessarily a bug, rather than a unsupported feature.

WW
  WimbledonW Chief Train Controller

Location: Sydney
I was writing a long reply when I must have hit a wrong key. Unsteady hands. SadSad

RP threw away what I had written so, which was most annoying.

I had to type the reply all over again.

I do not know which key or mouse movement caused this.

RP did not save an interim backup the attempted reply.


The only protection is to frequently submit the incomplete reply.

The Preview button is problematic due to bugs reported in a recently submitted in a Bug report. See https://www.railpage.com.au/f-po-editpost-2231433.htm
  YM-Mundrabilla Minister for Railways

Location: Mundrabilla but I'd rather be in Narvik
The answer, when/if composing something 'worthwhile', is to do the preparation in Word (for example) then copy and paste to RP.

I have found this method as both easier to compile and, more importantly, I will still have the original when RP throws away my efforts.

Doesn't happen all that often but it does happen.

There seems a clear relationship between the time and effort one expends and the likelihood of RP dumping it.

Could this be related to the time spent in the specific thread during the preparation of the post?
  WimbledonW Chief Train Controller

Location: Sydney
The answer, when/if composing something 'worthwhile', is to do the preparation in Word (for example) then copy and paste to RP.

I have found this method as both easier to compile and, more importantly, I will still have the original when RP throws away my efforts.

Doesn't happen all that often but it does happen.

There seems a clear relationship between the time and effort one expends and the likelihood of RP dumping it.

Could this be related to the time spent in the specific thread during the preparation of the post?
YM-Mundrabilla
I do use Word offline to edit larger and more complex Posts, as @YM-Mundrabilla wisely suggests.

But the lost post was only about 10 lines. Quitting with saving a backup counts as a bug in my eyes.

I should have submitted the lost post more often; however another RP user wonders why I do not use the flawed PREVIEW more and the SUBMIT button less.
  Sulla1 Chief Commissioner

Looks like a bug in the One Rail sale thread in Operators. Added a post, the thread won't load now...haven't seen that happen before.
  WimbledonW Chief Train Controller

Location: Sydney
Today on the ABC they reported a national petition about level crossing safety.

They wanted more Type F level crossing lights and also flashing strobe lights on the locos.

However RP would not allow a new thread to be created as the create button had disappeared.

What is going on?

I can still add to an existing thread, if I can find it, noting that the Search RP button doesn't seem to work.
  WimbledonW Chief Train Controller

Location: Sydney
When you answer a posted message, it is deleted as soon as you finish looking at it.

If you have to research something else for something, you do not seem to have the opportunity to resume your reply.
  Graham4405 The Ghost of George Stephenson

Location: Dalby Qld
When you answer a posted message, it is deleted as soon as you finish looking at it.
WimbledonW
What is deleted the post you are replying to or your reply? This isn't clear from your post.

If you have to research something else for something, you do not seem to have the opportunity to resume your reply.
WimbledonW
It isn't clear to me what you mean here either. Do your research in a different tab or window to the one you are posting in. It should then be as simple as returning to the tab or window that you are posting in.
  Graham4405 The Ghost of George Stephenson

Location: Dalby Qld
RP would not allow a new thread to be created as the create button had disappeared.
WimbledonW
The "+ New Thread" button is there for me, and it works.

I can still add to an existing thread, if I can find it, noting that the Search RP button doesn't seem to work.
WimbledonW
The simplest way to search RP is to use Google (or another preferred search engine), just add "site:Railpage.com.au" to your search phrase, eg "Adani Mine site:Railpage.com.au"
  Graham4405 The Ghost of George Stephenson

Location: Dalby Qld
Looks like a bug in the One Rail sale thread in Operators. Added a post, the thread won't load now...haven't seen that happen before.
Sulla1
This thread loads for me.
  justapassenger Minister for Railways

I do use Word offline to edit larger and more complex Posts, as @YM-Mundrabilla wisely suggests.

But the lost post was only about 10 lines. Quitting with saving a backup counts as a bug in my eyes.

I should have submitted the lost post more often; however another RP user wonders why I do not use the flawed PREVIEW more and the SUBMIT button less.
WimbledonW
The WYSIWYG editor in Railpage is very inefficient in the way it combines the worst of both HTML and Microsoft-style rich text.

You will do better if you use one of the following four options:
1. The "paste and match formatting" or "paste without formatting" command if your browser has one, switch to a better browser if it does not.
2. Compose posts in Notepad (or WordPad in plain text mode) rather than Word.
3. Best of all, learn to use BBcode. You'll quickly find that it is far quicker than stopping typing to faff around with the mouse.

I use BBcode, and don't have any issues with previewing posts.

Diagnosis: PEBKAC.
  Transtopic Chief Commissioner

Location: Sydney
Why can't Railpage fix this?  It's one of the most frustrating sites to use and it's been going on for years now.  I have literally spent hours composing posts, only to lose it all and having to start again.  Sometimes I just give up.  I have never struck this problem on any other sites.
  Graham4405 The Ghost of George Stephenson

Location: Dalby Qld
Why can't Railpage fix this?  It's one of the most frustrating sites to use and it's been going on for years now.  I have literally spent hours composing posts, only to lose it all and having to start again.  Sometimes I just give up.  I have never struck this problem on any other sites.
Transtopic
I've given up hope than any of the bugs reported over the past X years will ever be fixed...
  8502 Chief Train Controller

We are working on the new version of RP which is a new code base.

The problem you describe is probably resource related I will work on that today.
  8502 Chief Train Controller

Why can't Railpage fix this?  It's one of the most frustrating sites to use and it's been going on for years now.  I have literally spent hours composing posts, only to lose it all and having to start again.  Sometimes I just give up.  I have never struck this problem on any other sites.
Transtopic

I think I have now fixed this.
  Transtopic Chief Commissioner

Location: Sydney
Why can't Railpage fix this?  It's one of the most frustrating sites to use and it's been going on for years now.  I have literally spent hours composing posts, only to lose it all and having to start again.  Sometimes I just give up.  I have never struck this problem on any other sites.

I think I have now fixed this.
8502
Thanks.  I hope you're right.
  8502 Chief Train Controller

Why can't Railpage fix this?  It's one of the most frustrating sites to use and it's been going on for years now.  I have literally spent hours composing posts, only to lose it all and having to start again.  Sometimes I just give up.  I have never struck this problem on any other sites.

I think I have now fixed this.
Thanks.  I hope you're right.
Transtopic

Please let me know if there are any further issues.

Sponsored advertisement

Display from: