RP 3.9 Bugs and Feedback

 
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Hi guys,

We have a new version of Railpage live! This of course means a new Bugs and Feedback thread.

Please post your thoughts and bugfixes below Smile

Sponsored advertisement

  s3_gunzel Not a gunzel developer

Location: Western Sydney, AU
Posting from Dev as I can't get into Production. ERR_CONNECTION_REFUSED.
  railblogger Chief Commissioner

Location: At the back of the train, quitely doing exactly what you'd expect.
Wow! Love the new design, especially the login page. Although the previous font was better.
  bevans Site Admin

Location: Melbourne, Australia
Lots of new features and much to do. Jobs System, Ideas module and various other improvements.

We have some bugs to correct and I have spent all night getting the server back online.
  railblogger Chief Commissioner

Location: At the back of the train, quitely doing exactly what you'd expect.
Ok. I'm not sure if this is on the bug list, but quotes don't appear correctly, and when I try to quote a post, it gives me a blank page.
  bevans Site Admin

Location: Melbourne, Australia
Map does not appear in news item even though it appears in the admin edit screen.
  railblogger Chief Commissioner

Location: At the back of the train, quitely doing exactly what you'd expect.
I can't see my avatar nor can I replace it.
  bevans Site Admin

Location: Melbourne, Australia
Reply PM's for foum posts are not working.

Downloads are now not working at all. tested https://www.railpage.com.au/downloads/819/get

Reply with quote in forums not working.
  SAR523 Assistant Commissioner

Location: Chicago, IL
iOS device - when reading forums, the lead double quote is much larger than the text and obscures the first few words.
Also - I appear to have clicked the B for bold button while the page was loading and now can't get out of bold by clicking it again Smile.
  Brianr Assistant Commissioner

Location: Dunedin, New Zealand
It would be nice to have been warned. I have not had to log into RP for more than 5 years, have moved countries in that time. I just guessed my log in/password and luckily it worked.
  freightgate Minister for Railways

Location: Albury, New South Wales
The font is so large you have so little information on the screen. It is not compact like the previous version.  This needs a f lot of work. You have a front page with very spaced out information. Not good.  

Why change the theme constantly. The last one was quite workable.

The site is slow.

New features I have not looked at
  X'Trapolis-904M Deputy Commissioner

Location: Melbourne
Slow. Slower than my free hosting website.
  X'Trapolis-904M Deputy Commissioner

Location: Melbourne
Now railcams are broken!, even the edit button is broken.
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
We had some major issues with the production web server that runs Railpage yesterday. Halfway through the update process to bring it in-line with our development platform it had a catastrophic failure with the boot partition, which turned out to be a known issue with this version of Ubuntu. This meant waiting while a recovery image was uploaded to the datacentre, which took a loooong time. Eventually it got there. It's yet another issue we've had with Ubuntu and OS upgrades, so now the decision has been made to look at alternative platforms.

We've since then discovered some more faults with the production web server, including one where lsof runs rampant and gobbles up all our CPU time. We have plans to replace this web server, but as we're running at capacity VM-wise that involves a trip to Sydney with a new ESXi box.

It's very disappointing to see code that was so thoroughly tested on one web server and operate for months without failure rendered useless because of faults with another web server.
  bevans Site Admin

Location: Melbourne, Australia
Now railcams are broken!, even the edit button is broken.
X'Trapolis-904M

This issue is related to the actual image load.  Not the summary pages from what I can tell. Example: https://www.railpage.com.au/railcams/gheringhaploop/photo/16169471045
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Ok. I'm not sure if this is on the bug list, but quotes don't appear correctly, and when I try to quote a post, it gives me a blank page.
railblogger
This is now fixed Smile
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
It would be nice to have been warned. I have not had to log into RP for more than 5 years, have moved countries in that time. I just guessed my log in/password and luckily it worked.
Brianr
Like every other website we have a password reset function if you ever forget your password.
  JoppaJunction Chief Train Controller

Location: Banned
Some positive feedback.  I have discovered a new feature where on clicking discuss a news item the news item summary details now appear at the top of the thread which is the source of the discussion.  Like that!



Nice one guys!
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Thanks Smile That was a late addition.
  JoppaJunction Chief Train Controller

Location: Banned
Thanks Smile That was a late addition.
michaelgreenhill

I like it.  Off to snoop around for some new inclusions.  Thanks to all for the new release.  

I would say the fonts in terms of size are too big.  A lot of space wasted on the pages and a lot more scrolling required to get any reading done.
  David Peters Dr Beeching

Location: "With Hey Boy".
Avatars are not working and when you go to add your avatar you get a response that a error has happened and admin's etc have been notified. Also the site is very slow at the moment. But other than that so far a good job has been done on it!
  s3_gunzel Not a gunzel developer

Location: Western Sydney, AU
Thanks Smile That was a late addition.
michaelgreenhill
I just noticed, after testing too - Where's the donate link gone?

Also, trying to update my email:

Whoops! Mysqli prepare error: Table 'sparta.nuke_user' doesn't exist
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
When you try to cut and copy images into a post,  it does not work.
wxtre
This has never been a feature of Railpage and will not be in the immediate future.
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
I just noticed, after testing too - Where's the donate link gone?
s3_gunzel

Menu -> Website -> Donate


Also, trying to update my email:

Whoops! Mysqli prepare error: Table 'sparta.nuke_user' doesn't exist
s3_gunzel

Hurr-de-durr-de-durr, Michael can't remember database table names. Try again.
  michaelgreenhill Administrator That's Numberwang!

Location: Melbourne
Avatars are not working and when you go to add your avatar you get a response that a error has happened and admin's etc have been notified. Also the site is very slow at the moment. But other than that so far a good job has been done on it!
David Peters
Can you try again now?

Sponsored advertisement

Display from:   

Quick Reply

We've disabled Quick Reply for this thread as it was last updated more than six months ago.