Eureka R Class Arrives!

 
  linton78 Train Controller

Location: South Coast NSW
Yes what Aaron says is true a LED connected as a headlight will work perfectly in the forward movement but in reverse it will flicker because of the back EMF generated by the motor, it is irritating to say the least, but most locomotives ready to run have a light circuit in it that filters it out to stop this problem sounds like this is a case of the Chinese cheapening it up a bit more and not including the circuit for the lights.

It will not matter what you clean if this is the problem, it is just a thing that happens although it shouldn't though.

Just while we are on this subject would a higher value resistor on the LED lead cure this problem. I have one or two locomotives that do this most are home made installations though.
"David Peters"



Not too sure about the BEMF theory. Has anyone proved this? I am a little rusty on my DC motor theory but for BEMF to be generated the motor needs to be running. BEMF is generated by the armature windings cutting through the field permanent magnet lines of magnetic flux. This induced current opposes the current actually driving the motor and is almost a type of inbuilt regulation. The current flowing through the motor does not change direction, it is simply opposed slightly. I can not see how BEMF would affect the LED. The current does not reverse, BEMF decreases as the motor speed decreases. This opposing current is also fairly constant in relation to motor RPM. I would doubt that any flickering of sorts would be created. If you spun the motor by hand it may do something but I would love to see that also.

Obviously BEMF decoders use this opposing current to regulate the motor in which their driving, however I thought this occurred in the off period of the PWM cycle. The decoder handles all of this and the lighting function would be isolated from any BEMF feedback. I would imagine anyway.

As this R class is purely a DC locomotive I just can't see how the BEMF theory would work. I would be more open to the idea if it had a decoder as there may be a fault with it. Maybe one of the steering diodes is faulty or there is a slightly bridged solder joint. Who knows?

If it were my R Class I would send it back for repair or replacement. Eureka is aware of it and knows what the model should be doing.

Not sure? Would love to hear the theory spelt out. I know Aaron will be all over it ha ha.

Linton

Sponsored advertisement

  PeltonPinch Locomotive Fireman

Not too sure about the BEMF theory. Has anyone proved this? I am a little rusty on my DC motor theory but for BEMF to be generated the motor needs to be running. BEMF is generated by the armature windings cutting through the field permanent magnet lines of magnetic flux. This induced current opposes the current actually driving the motor and is almost a type of inbuilt regulation. The current flowing through the motor does not change direction, it is simply opposed slightly. I can not see how BEMF would affect the LED. The current does not reverse, BEMF decreases as the motor speed decreases. This opposing current is also fairly constant in relation to motor RPM. I would doubt that any flickering of sorts would be created. If you spun the motor by hand it may do something but I would love to see that also.

Not sure? Would love to hear the theory spelt out. I know Aaron will be all over it ha ha.

Linton
"linton78"


Linton,

You've actually provided your own proof, when you read your post.

The current due to BEMF, as you said, opposes the current that is driving to the motor. In order to do this, it must flow in the OPPOSITE direction. As this BEMF current is created by the action of the windings cutting the permanent magnet flux, it is still present when the main current is off, and the motor armature is still rotating. The polarity of the BEMF and the absence of the main current allows a current to flow in the opposing direction. This happens many times a second of course. And if the back emf generated is enough to overcome the forward voltage drop of an LED connected in parallel (which in many cases it will be) it will cause the LED to light in the off-cycle of the main motor current. This flickering happens when running in reverse as the BEMF current will now be in the "forward" direction!
  linton78 Train Controller

Location: South Coast NSW
Linton,

You've actually provided your own proof, when you read your post.

The current due to BEMF, as you said, opposes the current that is driving to the motor. In order to do this, it must flow in the OPPOSITE direction. As this BEMF current is created by the action of the windings cutting the permanent magnet flux, it is still present when the main current is off, and the motor armature is still rotating. The polarity of the BEMF and the absence of the main current allows a current to flow in the opposing direction. This happens many times a second of course. And if the back emf generated is enough to overcome the forward voltage drop of an LED connected in parallel (which in many cases it will be) it will cause the LED to light in the off-cycle of the main motor current. This flickering happens when running in reverse as the BEMF current will now be in the "forward" direction!
"PeltonPinch"



Not sure about that? The current does not reverse otherwise the motor would not continue turning. The current flows in the same direction. BEMF only opposes it, it does not reverse the current flowing though the motor, it simply lessens the affect the input current has. This is good as when the motor is loaded up the shaft speed decreases and BEMF decreases this results in an increase in mean current flow thus increasing motor torque.  

Your right if the power to the motor is cut you would see a reversal in current. Perhaps with a PWM DC controller it may make the LED flicker in off periods, while the motor still has momentum. I would not expect any one to be able to detect this though. Could be wrong of course. I wonder if the light flickers on high speed settings as normally the PWM affect decreases with controller output power increasing.

Has any one else seen this problem with their R Class models? As the owner of the company has said that it should be off while in reverse maybe there is in fact a fault on the loco and it should be sent back. That's what the warranty is for.

Getting closer to proving the theory. I am on the fence now.

Linton
  PeltonPinch Locomotive Fireman

When the motor is "motoring", the current is in the forward direction, limited by the opposition of the BEMF. (Think of it as 3 amps forward minus 2 amps backward leaves you with one amp in the forward direction). No current can flow backwards in the same circuit as a current flowing forwards, of course. When the power is removed, the motor is now effectively a generator, causing current (2A) to flow through the circuit in the opposite direction! On a Pwm, this will happen many times a second. Hence the flicker. A bit of DV/DT due to the collapsing magnetic field in the motor armature contributes to this as well, which is a sudden spike in back emf due to the supply switching off.

The thing is, this current is normally dissipated through a flyback arrangement at the controller in a pwm drive. Maybe just a diode and resistor, or maybe something more extravagant if you have a very fancy controller. Or if you have a real cheapie, perhaps not at all. But if it can find an easier path through an LED on the locomotive, it will.

Now, why the R class in question is doing this flickering I don't know, as au don't have one to check over. But I'd be interested in knowing what type of controller the faulty locomotive is being used on......
  linton78 Train Controller

Location: South Coast NSW
When the motor is "motoring", the current is in the forward direction, limited by the opposition of the BEMF. (Think of it as 3 amps forward minus 2 amps backward leaves you with one amp in the forward direction). No current can flow backwards in the same circuit as a current flowing forwards, of course. When the power is removed, the motor is now effectively a generator, causing current (2A) to flow through the circuit in the opposite direction! On a Pwm, this will happen many times a second. Hence the flicker. A bit of DV/DT due to the collapsing magnetic field in the motor armature contributes to this as well, which is a sudden spike in back emf due to the supply switching off.

The thing is, this current is normally dissipated through a flyback arrangement at the controller in a pwm drive. Maybe just a diode and resistor, or maybe something more extravagant if you have a very fancy controller. Or if you have a real cheapie, perhaps not at all. But if it can find an easier path through an LED on the locomotive, it will.

Now, why the R class in question is doing this flickering I don't know, as au don't have one to check over. But I'd be interested in knowing what type of controller the faulty locomotive is being used on......
"PeltonPinch"



Agree with you on all that. Once I considered the use of a PWM DC controller it suddenly dawned on me. It would be interesting to use a smooth DC source such as a battery or a specific train controller and see if the same thing happens with the flickering head light. I wonder just how intense the flickering light is? Full brilliance or just a dull flicker?

Good discussion! I was sceptical but now am pretty much a convert. I personally have never come across a model doing this but can see with the right controller and the right fault or error in design this may be possible.

Do others with R Class models see this happening? If it were me I would call Ron and talk about a fix.

All good. That's it for me in regards to Victorian locomotive discussion. There not even run on the right scale gauge track! Ha ha don't worry just kidding around. Please don't open this up again.
  Aaron The Ghost of George Stephenson

Location: University of Adelaide SA
When the motor is "motoring", the current is in the forward direction, limited by the opposition of the BEMF. (Think of it as 3 amps forward minus 2 amps backward leaves you with one amp in the forward direction). No current can flow backwards in the same circuit as a current flowing forwards, of course. When the power is removed, the motor is now effectively a generator, causing current (2A) to flow through the circuit in the opposite direction! On a Pwm, this will happen many times a second. Hence the flicker. A bit of DV/DT due to the collapsing magnetic field in the motor armature contributes to this as well, which is a sudden spike in back emf due to the supply switching off.

The thing is, this current is normally dissipated through a flyback arrangement at the controller in a pwm drive. Maybe just a diode and resistor, or maybe something more extravagant if you have a very fancy controller. Or if you have a real cheapie, perhaps not at all. But if it can find an easier path through an LED on the locomotive, it will.

Now, why the R class in question is doing this flickering I don't know, as au don't have one to check over. But I'd be interested in knowing what type of controller the faulty locomotive is being used on......
"PeltonPinch"
Correct, and yes there would be some sort of anti parallel or fly back diode to catch the reverse current pulses in a PWM controller, but it matters not what type of non DCC controller you have.

When the forward current from any DC source to the motor is killed by dirt or the track and/or wheels, at that very instant, the locomotive is open circuit to the controller. The BEMF is sourced to the formerly reverse biased LED by the mechanism you have stated and whatever suppression is built into your controller is not there to notice, or help - it's disconnected by the dirt.

This situation is often noticed on DC locomotives with tail lights blinking running forward, and headlights blinking running in reverse. The R class has no tail lights, so it's not noticeable there running forward, and whilst the headlight would be turning off when moving forward at the moments the light is blinking in reverse persistence of vision means that you don't see it.
  Aaron The Ghost of George Stephenson

Location: University of Adelaide SA
Just while we are on this subject would a higher value resistor on the LED lead cure this problem. I have one or two locomotives that do this most are home made installations though.
"David Peters"
No, what you actually need to do is place another diode, any old type, 1n4148 (my preference) or 1n4001 etc will do 'back to front' across the LED. That is banded end of the diode where you would expect the positive to be, non banded end to where you would expect the negative to be. It doesn't really matter whether this other diode goes just across the LED (my preference) or across the LED and resistor. The only key thing is that this new diode HAS TO BE LED side of your 'direction' diode.

Often, I use a surface mount diode (probably a '1206' size) and solder it backwards right across the leads of the 3mm LED right up against the epoxy. Not difficult to do, just not necessarily a beginner's soldering excercise.
  David Peters Dr Beeching

Location: "With Hey Boy".
No, what you actually need to do is place another diode, any old type, 1n4148 (my preference) or 1n4001 etc will do 'back to front' across the LED. That is banded end of the diode where you would expect the positive to be, non banded end to where you would expect the negative to be. It doesn't really matter whether this other diode goes just across the LED (my preference) or across the LED and resistor. The only key thing is that this new diode HAS TO BE LED side of your 'direction' diode.

Often, I use a surface mount diode (probably a '1206' size) and solder it backwards right across the leads of the 3mm LED right up against the epoxy. Not difficult to do, just not necessarily a beginner's soldering excercise.
Aaron

Thanks Aaron I will give it a shot and see what happens. Most RTR locomotives that I have, do not have this problem though because the circuit board does the job of filtering it out.

And to those that have never seen it it is just a dull flickering really but it is visible to the human eye and is annoying, When going forward and the LED is lit the right way there is no problem just a nice bright light.
  Roachie Chief Commissioner

Location: Kadina SA (formerly NSW)
This must be something that is peculiar to QSI decoders. I have altered the CVs on my Tsunami decoders so that the headlight stays on (assuming I have it ON in the first place of course), even when I place the loco in reverse.

This is one aspect of our model locos that used to irk me.....IE: the way the headlight at one end goes OFF and the one at the other end comes ON each time the loco changes direction!

In my experience, say a train